quinta-feira, 31 de março de 2011

Robô explorador - Motores e Transmissão

A postagem de hoje sobre o robô explorador é sobre os motores e a transmissão dupla, no ínicio eu tinha pensado em usar uma transmissão simples e um servo para fazer o direcionamento do veículo (robô), mas depois percebi que com 2 motores o robô iria conseguir girar sobre seu próprio eixo, ou seja, dar a volta sem sair do lugar. Para que isso funcionasse os motores precisariam fornecer um bom torque, mas o principal é uma velocidade alta, para dar agilidade ao mesmo.
Como transmissão, escolhi o Kit da imagem ao lado de motor e transmissão da Tamiya, com redução máxima eu consigo uma proporção de 203:1, é uma redução boa e assim continuo tendo um pouco mais de velocidade/agilidade no robô.
Os motores que vem nesse kit são os Mabuchi FA-130RA, que operam em 3V, mas serão alimentados com uma tensão de 3,6V. Este motor pesa apenas 17 gramas e é capaz de girar a cerca de 12.300 RPM sem carga no eixo.
Motor escolhido surge o problema, motores brushed geram ruídos e eles interferem no funcionamento do microcontrolador, alterando o clock, e para piorar a situação, estou utilizando 2 motores desses na transmissão. Para resolver o problema coloquei 3 capacitores cerâmicos de 100nF nos terminais dos motores, ficou a cargo deles absorver os ruídos causados pelas escovas dos motores, e para melhorar o circuito, os motores são alimentados por fontes diferentes, então tenho uma alimentação lógica (para a CPU do robô e os LEDs) e alimentação de potência (motores e armas do robô). Segue a baixo uma foto de como ficou os terminais dos motores com os capacitores cerâmicos:
Depois de bem lubrificados internamente, remontados, capacitores soldados no lugar coloquei os motores na transmissão dupla já montada com a relação definitiva.

Nessa imagem dá para ver os fios e os conectores que serão "conectados" na ponte H responsável por impulsionar tudo, mas isso, já é assunto para outro post.
Bom pessoal, por hoje era isso, a meta agora é voltar a trabalhar no rádio controle do robô e terminar ele o quanto antes.

Fontes:
- Motor Mabuchi FA-130 no site da Pololu;
- Transmissão dupla Tamiya no site da Pololu;
- Datasheet do motor Mabuchi FA-130;
- Fórum Robocore, postagem sobre ruídos causados por motores.

quinta-feira, 17 de março de 2011

Eric Schmidt é entrevistado pela Globo News

A postagem de hoje é sobre a entrevista de Eric Schmidt à Globo News no escritório da empresa em São Paulo. Na entrevista o CEO da Google diz que não se importa muito com o fato do Facebook ter passado o Google em page views, pois o Facebook não é seu concorrente, o verdadeiro concorrente deles é a... (adivinha!) Microsoft, (acho que talvez seja por isso que eles não se importam muito com o orkut).
Ele está deixando o cargo que será assumido pelo Larry Page enquanto ele assume o cargo de conselho da empresa, Larry irá focar no controle do negócio e na estratégia dos produtos, enquanto Eric vai focar nas parcerias, clientes e a empresa (assuntos externos).
Vale a pena assistir a entrevista na íntegra, você pode assistir neste link (site da Globo News), e para quem precisa saber da duração antes de clicar no link, a entrevista dura 22 minutos, apenas uma fração do tempo que normalmente você fica no MSN em horário de trabalho. =] 
Por hoje é isso, até a próxima.
 
Fonte:
- Google Discovery (blog oficial do Google);

terça-feira, 15 de março de 2011

Robô explorador - acionador dos LEDs de iluminação

Um circuito que já montei e faltava publicar no blog é o sistema acionador dos leds, basicamente ele possui o mesmo circuito elétrico que o circuito acionador do cooler da ponte H, a diferença básica é que ao invéz de possuir uma única saída ele possui 4 que são utilizadas pelos LEDs de iluminação frontal, LEDs de iluminação da câmera e 2 LEDs que piscam alternando entre azul e vermelho que serão colocados na parte traseira do robô para sinalização.
A seguir a imagem do circuito acionador:
Na imagem é possivel ver os parafusos de fixação bem como o conector padrão futaba utilizado para ligar o sistema ao CPU do robô (lembra do diagrama de blocos dele??). Talvez eu ainda tenha que fazer alguns ajustes nesse sistema, mas será pouca coisa a princípio.
Aqui uma foto dos LEDs de iluminação da câmera:
O conector possui indicação de "positivo" e "negativo" para que seja colocado de forma correta, a seguir a imagem dos LEDs de iluminação frontal e dos LEDs de sinalização:
 
Os LEDs dispostos em forma triângular são de iluminação frontal, os outros menores são de sinalização e ficam escondidos no robô de forma que só será possivel ver a luz emitida por eles quando esta iluminar o chão.

Sobre o circuito a postagem termina aqui, agora vamos ver o que ainda falta no robô:
- Armas e sistema de disparo;
- Câmera (essa etapa não tem nem previsão para ser feita e/ou concluída - provavelmente  será a última etapa);
- Chassi;
- Controle remoto;
- CPU; 
- Motores, transmissão e esteiras;
- Ponte H de acionamento dos motores;
- Programação;
- Sistema de alimentação;
Pelo que lembro é isso, no momento já estou trabalhando no controle remoto do robô (já faz umas 2 semanas no mínimo), algumas coisas já estão prontas ou quase, só falta as fotos e redigir o texto para postar aqui no blog.
Por hoje era isso, até a próxima.

sexta-feira, 4 de março de 2011

Robô explorador - Atualizações

Já estava devendo outra postagem sobre o robô explorador visto que a meta é uma postagem a cada 15 ou 20 dias, hoje é apenas para noticiar como está o andamento do projeto, algumas noticias boas, outras nem tanto.
Estou tendo um pouco de problemas com o controle remoto já que eu estou montando do zero o meu com todas as funções que desejo (bem personalizado, não acha?!) em especial na transmissão e recepção dos dados, a programação está ok, o desafio esta sendo o módulo receptor funcionar corretamente, estou tendo problemas de interferência. 
O módulo receptor está recebendo sinal mesmo o transmissor estando desligado (sei disso pois coloquei um LED no emissor e no receptor, sempre que há transmissão de dados os LEDs piscam), algumas vezes ele toma decisões próprias (meio dificil de entender isso!!..) pois o cooler da ponte H desliga sozinho sem eu ter enviado o comando para tal função (e ainda não adicionei o código de desligamento automático em razão da temperatura). 
Comprei este conjunto de transmissor e receptor, e a principio estou ligando diretamente no TX e RX de 2 Atmega328 segundo esse tutorial, acho que vou ter que recomeçar do zero essa parte e ver se errei alguma coisa no meio do caminho..
Outra novidade é no circuito acionador da ponte H, na postagem sobre ele você pode ver a "gambiarra" para arrumar o fio no padrão Futaba, dando uma pesquisada no Mercado Livre encontrei o tal fio neste anuncio, assim que chegou a mercadoria fiz a alteração, ficou muito melhor e mais bem acabado.
Já montei também o circuito acionador do sistema de iluminação, é muito semelhante ao do cooler, apenas com mais saídas para todos os LEDs, só estou esperando os LEDs brancos de alto brilho chegar para  finalizar o sistema, aí já posto aqui o resultado.
O último circuito a ser testado será o do acionamento dos canhões de pólvora, sei que o robô tem nome de explorador, mas, e se em uma "exploração" ele encontra um inimigo? hehehe O canhão a principio irá disparar uma mini lança de madeira em chamas com uns 45º em relação ao solo, então a distância máxima alcançada pelo projetil irá depender da sua velocidade, que por sua vez depende da quantidade de pólvora no momento do disparo (sim, essa parte é um pouco mais complicada), mas no momento que eu estiver montando esse circuito faço uma postagem mais detalhada sobre ele.
Falta ainda uma postagem do chassi do robô e do sistema de locomoção, assim que estiver mais bem alinhado e testado escrevo a postagem aqui, a pintura do robô é o de menos pois já tenho as tintas, o pior será conseguir um verniz para dar acabamento, pois o frete é que me mata.. :(
Por hoje é isso, assim que possuir atualizações do robô coloco aqui, até mais.